注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

断尘居

温柔的男人像海洋。

 
 
 
 
 

日志

 
 

Nginx installation: ./configure: error: the HTTP rewrite module requires the PCRE library.  

2014-10-09 10:23:15|  分类: Nginx/Apache |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

 # 软件环境丨Software Environments

OS: CentOS 6.5 minimal
Proxy Server: Nginx 1.6.2

 # 问题描述丨Problem Introduction

I installed a new linux server of CentOS 6.5 minimal yesterday, as we know it dosn't contain any optional software packages but a basic system platform. I tried to compile the source code and install Nginx just now, it threw to me such error message below.
./configure: error: the HTTP rewrite module requires the PCRE library.
You can either disable the module by using --without-http_rewrite_module
option, or install the PCRE library into the system, or build the PCRE library
statically from the source with nginx by using --with-pcre=<path> option.

 # 解决方案丨The Solution

obviously, from the text we can learn that it require the HTTP module and the PCRE library, so I ended up this situation with running over the following command.
[root@BobServerStation nginx-1.6.2]#yum -y install openssl openssl-devel pcre-devel

then run ./configure again and everything is OK.

 
日志格式 - Bob.Z - 断尘居
 文章作者:Bob.Z 编写时间:2014年10月09日
 E-mail:zhaohevip@gmail.com 最后修正:2014年10月09日
 申明:本文章版权完全断尘居博主所有,转载请在本文底部留言并注明本文链接。

  评论这张
 
阅读(581)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017